ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 16009. Открытый вариант

Алгоритм вычисления значения функции F(n), где n – целое число, задан следующими соотношениями:

F(n)=n при n ≥ 2025;
F(n)= n × 2 + F(n+2), если n < 2025

Чему равно значение выражения F(82) — F(81)?

def f(n):
    if n >= 2025:
        return n
    else:
        return n * 2 + f(n + 2)


print(f(82) - f(81))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие