ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 15103. Типовая задача

Обозначим через ТРЕУГ(n, m, k) утверждение «существует невырожденный треугольник с длинами сторон n, m, k».

Для какого наибольшего натурального числа А логическое выражение ¬((ТРЕУГ(x, 12, 20) ≡ (¬(МАКС(x, 5) > 23))) ∧ ТРЕУГ(x, А, 3)) истинно (т.е. принимает значение 1) при любом натуральном значении переменной x?

Примечание. МАКС(a, b) = a, если a > b и МАКС(a, b) = b, если a ≤ b.

def treug(n, m, k):
    x, y, z = sorted((n, m, k))
    return x + y > z


def f(x, A):
    return not ((treug(x, 12, 20) == (not (max(x, 5) > 28))) and treug(x, A, 3))

for A in range(1, 10)[::-1]:
    if all(f(x, A) for x in range(1, 10)):
        print(A)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие