ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 15102. Типовая задача

Обозначим через ДЕЛ(n, m) утверждение «натуральное число n делится без остатка на натуральное число m».

Для какого наименьшего натурального числа A логическое выражение ¬ДЕЛ(x, A) →  (ДЕЛ(x, 54) → ¬ДЕЛ(162, x)) истинно (т.е. принимает значение 1) при любом целом положительном значении переменной x?

def f(x, A):
    return (x % A != 0) <= ((x % 54 == 0) <= (162 % x != 0))


for A in range(1, 100)[::-1]:
    if all(f(x, A) for x in range(1, 100)):
        print(A)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие