ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 15104. Типовая задача

На числовой прямой дан отрезок A = [3; 60]; B – множество всех натуральных делителей числа 177, отличных от единицы и от самого числа 177; C – множество всех натуральных делителей некоторого натурального числа y, отличных от единицы и от самого числа y (число y таково, что множество C непустое).

Укажите наибольшее возможное значение числа y, для которого выражение (x ∈ C) → ((x ∈ A) ∧ ¬ (x ∈ B)) истинно (т.е. принимает значение 1) при любом значении переменной x.

def f(x, y):
    A = 3 <= x <= 60
    B = 177 % x == 0 and x != 1 and x != 177
    C = y % x == 0 and x != 1 and x != y
    return C <= (A and not B)

for y in range(1, 10_000)[::-1]:
    divs = [d for d in range(2, int(y ** 0.5) + 1) if y % d == 0]
    if divs and all(f(x, y) for x in range(1, 10_000)):
        print(y)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие