ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 15022. Основная волна

Для какого наименьшего целого неотрицательного числа A выражение (x < A) ∧ (y < 3A) ∨ (2x + y > 128) тождественно истинно, т.е. принимает значение 1 при любых целых положительных x и y?

def f(x, y, A):
    return (x < A) and (y < 3 * A) or (2 * x + y > 128)


for A in range(0, 100):
    if all(f(x, y, A) for x in range(1, 100) for y in range(1, 100)):
        print(A)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие