ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 15023. ЕГКР 2024

Обозначим через m & n поразрядную конъюнкцию неотрицательных целых чисел m и n. Так, например, 14 & 5 = 11102 & 01012 = 01002 = 4.

Для какого наибольшего целого положительного числа А логическое выражение (x & А = 0) ∨ ¬(x & 37 = 0) ∨ ¬(x & 12 = 0) истинно (т.е. принимает значение 1) при любом целом значении переменной х?

def f(x, A):
    return (x & A == 0) or (not (x & 37 == 0)) or (not (x & 12 == 0))


for A in range(1, 100)[::-1]:
    if all(f(x, A) for x in range(1, 100)):
        print(A)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие