ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 15021. Основная волна

Для какого наименьшего целого неотрицательного числа A выражение (2x + y ≠ 110) ∨ (x < y) ∨ (A < x) тождественно истинно, т.е. принимает значение 1 при любых целых положительных x и y?

def f(x, y, A):
    return (2 * x + y != 110) or (x < y) or (A < x)


for A in range(0, 100)[::-1]:
    if all(f(x, y, A) for x in range(1, 50) for y in range(1, 50)):
        print(A)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие