ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 15014. ЕГКР

На числовой прямой даны два отрезка: B = [36; 75] и C = [60; 110].

Укажите наименьшую возможную длину такого отрезка A, что логическое выражение ¬(x ∈ A) → ((x ∈ B) ≡ (x ∈ C)) истинно (т.е. принимает значение 1) при любом значении переменной х.

from itertools import combinations


def f(x):
    B = 36 <= x <= 75
    C = 60 <= x <= 110
    A = A1 <= x <= A2
    return (not A) <= (B == C)


line_A = sorted([36, 75, 60, 110])
line_x = [36.5, 75.5, 60.5]

ans = []
for A1, A2 in combinations(line_A, 2):
    if all(f(x) for x in line_x):
        ans.append(A2 - A1)

print(min(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие