ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 15013. Досрочная волна

Для какого наименьшего целого неотрицательного числа А логическое выражение (5 < y) ∨ (x > 32) ∨ (x + 2y < A) тождественно истинно (т.е. принимает значение 1) при любых целых неотрицательных x и y?

def f(x, y, A):
    return ((5 < y) or (x > 32) or (x + 2 * y < A))


for A in range(0, 50):
    if all(f(x, y, A) for x in range(1, 50) for y in range(1, 50)):
        print(A)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие