ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14020. Основная волна 2023

Операнды арифметического выражения записаны в системе счисления с основанием 22.

18x8995722 + 80x3322 + 521x622

В записи чисел переменной x обозначена неизвестная цифра из алфавита 22-ричной системы счисления. Определите наименьшее значение x, при котором значение данного арифметического выражения кратно 21.

Для найденного значения x вычислите частное от деления значения арифметического выражения на 21 и укажите его в ответе в десятичной системе счисления. Основание системы счисления указывать не нужно.

from string import printable as alph

ans = []
for x in alph[:22]:
    num_1 = int(f'18{x}89957', 22)
    num_2 = int(f'80{x}33', 22)
    num_3 = int(f'521{x}6', 22)
    num = num_1 + num_2 + num_3
    if num % 21 == 0:
        ans.append([x, num // 21])

print(min(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие