ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 9024. Основная волна 2024

Откройте файл электронной таблицы, содержащей в каждой строке четыре натуральных числа. Определите количество строк таблицы, содержащих числа, для которых выполнены оба условия:

– наибольшее из четырёх чисел меньше суммы трёх других;
 – среди четырёх чисел есть только одна пара равных чисел.

В ответе запишите только число.

with open('902.txt') as f:
    data = [list(map(int, i.split())) for i in f]


# Условие 1
def f1(line):
    # Наибольшее
    max_of_4 = max(line)
    # Сумма трёх других
    sum_of_3 = sum(line) - max(line)
    # Наибольшее меньше суммы трёх других
    return max_of_4 < sum_of_3


# Условие 2
def f2(line):
    # Числа повторяются дважды
    rep_pair = [i for i in line if line.count(i) == 2]
    # Только одна пара равных
    return len(rep_pair) == 2


# Счетчик
count = 0

# Вычисление кол-ва строк
for line in data:
    if f1(line) and f2(line):
        count += 1

# Вывод ответа
print(count)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие