ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 8041. Резервная волна 2025

Сколько существует семеричных пятизначных чисел, содержащих в своей записи ровно одну цифру 6 и не содержащих идущих подряд одинаковых цифр?

from itertools import product

alph = '0123456'

count = 0
for val in product(alph, repeat = 5):
    val = "".join(val)
    if (val[0] != '0'
            and val.count('6') == 1
            and all(val[i] != val[i+1] for i in range(4))):
        count += 1

print(count)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие