ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 8036. Досрочная волна 2025

Виктор составляет таблицу кодовых слов для передачи сообщений, каждому сообщению соответствует своё кодовое слово. В качестве кодовых слов Виктор использует 5-буквенные слова, в которых могут быть только буквы Д, Г, И, А, Ш, Э, причём слово не должно начинаться с гласной или заканчиваться согласной.

Сколько различных кодовых слов может использовать Виктор?

from itertools import *

cnt = 0
for s in product('ДГИАШЭ', repeat=5):
    s = ''.join(s)
    c1 = s[0] not in 'ИАЭ'
    c2 = s[-1] not in 'ДГШ'
    if c1 and c2:
        cnt += 1
print(cnt)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие