ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 8035. Апробация 2025

Определите количество 9-ричных пятизначных чисел, в записи которых ровно одна цифра 0, при этом никакая нечётная цифра не стоит рядом с цифрой 0.

from itertools import product

alph = '012345678'
wrong_pairs = {'10', '30', '50', '70',
               '01', '03', '05', '07'}


count = 0
for val in product(alph, repeat = 5):
    val = "".join(val)
    if (val[0] != '0' 
            and val.count('0') == 1 
            and all(pair not in val for pair in wrong_pairs)):
        count += 1

print(count)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие