ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 6212. Авторская задача

Исполнитель Чертёжник действует на плоскости с декартовой системой координат, в которой единица длины по каждой из осей соответствует одному сантиметру. В начальный момент Чертёжник находится в начале координат, перо опущено. При опущенном пере Чертёжник оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя.

У исполнителя существует 3 команды: Поднять перо, означающая переход к перемещению без рисования; Опустить перо, означающая переход в режим рисования; Сместиться x, y (где x, y — целые числа), вызывающая перемещение Чертёжника из текущего положения в точку с координатами x, y.

Чертёжнику был дан для исполнения следующий алгоритм:

Сместиться 20, 40
Опустить перо
Сместиться 40, 60
Сместиться 80, 68
Сместиться 90, 40
Сместиться 40, 20
Сместиться 20, 40
Поднять перо
Сместиться 44, 76
Опустить перо
Сместиться 74, 76
Сместиться 74, 24
Сместиться 44, 16
Сместиться 44, 76

Определите, сколько точек с целочисленными координатами будут находиться внутри пересечения фигур, ограниченных заданными алгоритмом линиями. Точки на линии учитывать не следует.

import math as m
from turtle import *

tracer(0)

teleport(20, 40)

# --- if Python < 3.12 ---
# pu()
# goto(20,40)
# pd()
# --- end if ---

# Первая фигура
begin_poly()
goto(40, 60)
goto(80, 68)
goto(90, 40)
goto(40, 20)
goto(20, 40)
end_poly()

coords_1 = get_poly()
angles_1 = []
count = 0

for coord in coords_1[1:]:
    angles_1.append(towards(*coord))
    goto(coord)

teleport(44, 76)

# Вторая фигура
begin_poly()
goto(74, 76)
goto(74, 24)
goto(44, 16)
goto(44, 76)
end_poly()

coords_2 = get_poly()
angles_2 = []

for coord in coords_2[1:]:
    angles_2.append(towards(*coord))
    goto(coord)

k_1 = round(m.tan(m.radians(angles_1[1])), 8)
k_3 = round(m.tan(m.radians(angles_1[3])), 8)

b_1 = coords_1[1][1] - k_1 * coords_1[1][0]
b_3 = coords_1[3][1] - k_3 * coords_1[3][0]

# между x=44 и x=74 (от 45 до 73)
for x in range(45, 74):
    for y in range(0, 75):
        if k_3 * x + b_3 < y < k_1 * x + b_1:
            count += 1

print(count)
update()
done()
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие