ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 6107. Типовая задача

Исполнитель Черепаха действует на плоскости с декартовой системой координат.

В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост поднят.
При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения.

У исполнителя существует 6 команд: Поднять хвост, означающая переход к перемещению без рисования; Опустить хвост, означающая переход в режим рисования; Вперёд n (где n — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова; Назад n (где n — целое число), вызывающая перемещение в противоположном голове направлении; Направо m (где m — целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Налево m (где m — целое число), вызывающая изменение направления движения на m градусов против часовой стрелки.

Запись Повтори k [Команда 1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм:

Вперёд 100 Направо 90 Вперёд 100 Направо 45 Опустить хвост Повтори 15 [Вперёд 20 Направо 90 Вперёд 30 Направо 90]

Определите, сколько точек с целочисленными координатами будут находиться внутри области, ограниченной линией, заданной данным алгоритмом. Точки на линии учитывать не следует.

import math as m
from turtle import *

# Базовая настройка
tracer(0)  # Отключаем анимацию
# Переменные
angles = []
coords = []
count = 0

lt(90)
pu()

# Алгоритм
fd(100)
rt(90)
fd(100)
rt(45)
pd()
for i in range(15):
    if i < 2:
        angles.append(heading())
        coords.append((xcor(), ycor()))
    fd(20)
    rt(90)
    if i < 2:
        angles.append(heading())
        coords.append((xcor(), ycor()))
    fd(30)
    rt(90)

update()

k_1 = round(m.tan(m.radians(angles[0])), 8)
k_2 = round(m.tan(m.radians(angles[1])), 8)

b_1 = coords[0][1] - k_1 * coords[0][0]
b_2 = coords[1][1] - k_2 * coords[1][0]
b_3 = coords[2][1] - k_1 * coords[2][0]
b_4 = coords[3][1] - k_2 * coords[3][0]

for x in range(0, 200):
    for y in range(0, 200):
        if k_1 * x + b_3 < y < k_1 * x + b_1 and 
                k_2 * x + b_2 < y < k_2 * x + b_4:
            count += 1

print(count)
done()
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие