ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 5040. Основная волна 2025

На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом.

  1. Строится троичная запись числа N.
  2. Далее эта запись обрабатывается по следующему правилу:
    • если число N делится на 3, то к этой записи дописываются две последние троичные цифры;
    • если число N на 3 не делится, то остаток от деления умножается на 5, переводится в троичную запись и дописывается в конец числа.
      Полученная таким образом запись является троичной записью искомого числа R.
  3. Результат переводится в десятичную систему и выводится на экран.

Например, для исходного числа 1110 = 1023 результатом является число 1021013 = 30710, а для исходного числа 1210 = 1103 это число 110103 = 11110.

Укажите минимальное число R, большее 150, которое может быть получено с помощью описанного алгоритма.

В ответе запишите это число в десятичной системе счисления.

def to_ternary(num):
    result = ''
    while num:
        result += str(num % 3)
        num //= 3
    return result[::-1]


ans = []
for N in range(1, 100):
    N_tern = to_ternary(N)
    remainder = N % 3
    if remainder == 0:
        N_tern += N_tern[-2:]
    else:
        N_tern += to_ternary(remainder * 5)
    R = int(N_tern, 3)
    if R > 150:
        ans.append(R)

print(min(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие