ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 26200. Авторская задача

Входной файл содержит сведения о заявках на заправку грузовиков на станции обслуживания. В каждой заявке указаны время начала заправки грузовика и объем топлива, который необходимо залить в бак. Наполнение бака десятью литрами топлива занимает одну минуту, двадцатью литрами - две минуты и т.д. Если бак необходимо заполнить объемом топлива, некратным десяти, то считаем, что станция занята полную минуту. Если станция заправки занята одним грузовиком, то другие грузовики не могут заехать на станцию. Если время прибытия грузовика выпадает на период, когда станция занята, менеджер отклоняет заявку. Если время прибытия грузовика совпадает со временем окончания заправки, то прибывший грузовик может начать заправляться с минуты своего прибытия. Определите, какое максимальное количество грузовиков можно обслужить на станции и каков максимальный объем залитого топлива.

Входные данные

В первой строке входного файла находится натуральное число N (N ≤ 1000) – количество заявок на заправку. Следующие N строк содержат пары чисел, обозначающих время прибытия грузовика и объем топлива. Каждое из чисел натуральное, не превосходящее 1440.
Запишите в ответе два числа: максимальное количество грузовиков, которые можно обслужить, и максимальный объем залитого топлива (в литрах).

Типовой пример организации данных во входном файле
5
20 876
100 350
131 140
150 310
120 200

При таких исходных данных можно заправить максимум три грузовика, например 1, 4, 5. Максимальный объем топлива - 1386.

Типовой пример имеет иллюстративный характер. Для выполнения задания используйте данные из прилагаемых файлов.

from math import ceil

with open('2600.txt') as file:
    N = int(file.readline())
    trucks = []
    for i in file:
        num1, num2 = map(int, i.split())
        trucks.append([num1, num1 + ceil(num2 / 10), num2])

trucks = sorted(trucks, key=lambda x: (x[1], x[0]))

station = [trucks[0]]
gas = trucks[0][2]
for truck in trucks:
    if station[-1][1] <= truck[0]:
        station.append(truck)
        gas += truck[2]

print(len(station), gas)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие