ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 24106. Типовая задача

Текстовый файл состоит из символов A, B, C, D, E.

Определите в прилагаемом файле максимальное количество идущих подряд символов, среди которых комбинация символов AB встречается ровно 21 раз.

with open('2426.txt', 'r') as file:
    data = file.readline()

data = data.replace("AB", "A B").split()

length = 0

for i in range(len(data) - 21):
    substring = "".join(data[i:i + 22])
    length = max(length, len(substring))
print(length)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие