ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 24105. Типовая задача

Текстовый файл состоит из символов A, B, C, D, E.

Определите в прилагаемом файле максимальное количество идущих подряд символов, среди которых символ A встречается не более 3 раз.

import re

with open('2425.txt') as f:
    s = f.readline()

ans = 0

for m in re.finditer(r'(?=([^A]*(?:A[^A]*){0,3}))', s):
    ans = max(ans, len(m.group(1)))

print(ans)

#= split = #

with open('2425.txt') as f:
    s = f.readline()

parts = s.split('A')

ans = 0

for i in range(len(parts) - 3):
    current_len = sum(len(parts[j]) for j in range(i, i + 4)) + 3
    ans = max(ans, current_len)

print(ans)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие