ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 23200. Авторская задача

Исполнитель преобразует число на экране.

У исполнителя есть три команды, которые обозначены латинскими буквами:
A. Прибавить 1
B. Умножить на 3
С. Умножить на 5

Программа для исполнителя – это последовательность команд.
Сколько существует программ, для которых при исходном числе 2 результатом является число 90, при этом траектория вычислений не содержит чисел 18 и 30 ?

Траектория вычислений программы – это последовательность результатов выполнения всех команд программы.
Например, для программы СBA при исходном числе 2 траектория будет состоять из чисел 10, 30, 31.

def f(x, y):

    if x == y:
        return 1

    if x > y or x == 18 or x == 30:
        return 0

    if x < y:
        return (f(x + 1, y) + f(x * 3, y) + f(x * 5, y))


print(f(2, 90))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие