ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 19100. Типовая задача

Задание 19

Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежат две кучи камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в одну из куч (по своему выбору) два камня или увеличить количество камней в куче в три раза. Для того, чтобы делать ходы, у каждого игрока есть неограниченное количество камней.

Игра завершается в тот момент, когда суммарное количество камней в кучах становится не менее 136. Победителем считается игрок, сделавший последний ход, т.е. первым получивший такую позицию, при которой в кучах находится 136 камней или больше.

В начальный момент в первой куче было 2 камня, во второй куче — S камней; 1 ≤ S ≤ 132.

Будем говорить, что игрок имеет выигрышную стратегию, если он может выиграть при любых ходах противника.

Известно, что Ваня выиграл своим первым ходом после неудачного хода Пети. Укажите минимальное значение S, когда такая ситуация возможна.

Задание 20

Для игры, описанной в задании 19, найдите два наименьших значения S, при которых у Пети есть выигрышная стратегия, причём одновременно выполняются два условия:

− Петя не может выиграть за один ход;

− Петя может выиграть своим вторым ходом независимо от того, как будет ходить Ваня.

Найденные значения запишите в ответе в порядке возрастания.

Задание 21

Для игры, описанной в задании 19, найдите минимальное значение S, при котором одновременно выполняются два условия:

– у Вани есть выигрышная стратегия, позволяющая ему выиграть первым или вторым ходом при любой игре Пети;

– у Вани нет стратегии, которая позволит ему гарантированно выиграть первым ходом.

Если найдено несколько значений S, в ответе запишите наименьшее из них.

def f_19(x, y, s):
    if x + y >= 136:
        return s % 2 == 0

    if s == 0:
        return False

    h = [f_19(x + 2, y, s - 1),
         f_19(x, y + 2, s - 1),
         f_19(x * 3, y, s - 1),
         f_19(x, y * 3, s - 1)]
    return any(h)


def f_20_21(x, y, s):
    if x + y >= 136:
        return s % 2 == 0

    if s == 0:
        return False

    h = [f_20_21(x + 2, y, s - 1),
         f_20_21(x, y + 2, s - 1),
         f_20_21(x * 3, y, s - 1),
         f_20_21(x, y * 3, s - 1)]

    if (s + 1) % 2 == 0:
        return any(h)
    else:
        return all(h)


print('19:', min([s for s in range(1, 132) if
                  f_19(2, s, 2)]))

print('20:', *[s for s in range(1, 132) if
               f_20_21(2, s, 3) and not
               f_20_21(2, s, 1)])

print('21:', min([s for s in range(1, 132) if
                  f_20_21(2, s, 4) and not
                  f_20_21(2, s, 2)]))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие