ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 19040. Основная волна 2025

Задание 19

Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежит куча камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может:

- убрать из кучи 3 камня;

- убрать из кучи 8 камней;

- уменьшить количество камней в куче в 3 раза (количество камней, полученное при делении, округляется до меньшего).

Например, из кучи в 20 камней за один ход можно получить кучу из 17, 12 или 6 камней.

Игра завершается, когда количество камней в куче становится не более 16. Победителем считается игрок, сделавший последний ход, то есть первым получивший кучу из 16 или менее камней. В начальный момент в куче было S камней, S ≥17.

Будем говорить, что игрок имеет выигрышную стратегию, если он может выиграть при любых ходах противника.

Укажите минимальное значение S, при котором Петя не может выиграть за один ход, но при любом ходе Пети Ваня может выиграть своим первым ходом.

Задание 20

Для игры, описанной в задании 19, найдите два наименьших значения S, при которых у Пети есть выигрышная стратегия, причём одновременно выполняются два условия:

- Петя не может выиграть за один ход;

- Петя может выиграть своим вторым ходом независимо от того, как будет ходить Ваня.

Найденные значения запишите в ответе в порядке возрастания.

Задание 21

Для игры, описанной в задании 19, найдите минимальное значение S, при котором одновременно выполняются два условия:

- у Вани есть выигрышная стратегия, позволяющая ему выиграть первым или вторым ходом при любой игре Пети;

- у Вани нет стратегии, которая позволит ему гарантированно выиграть первым ходом.

def f(x, s):
    if x <= 16:
        return s % 2 == 0

    if s == 0:
        return False

    h = [f(x - 3, s - 1), f(x - 8, s - 1), f(x // 3, s - 1)]
    return any(h) if (s - 1) % 2 == 0 else all(h)


print('19:', min([s for s in range(17, 100) if f(s, 2)]))
print('20:', *[s for s in range(17, 100) if f(s, 3) and not f(s, 1)][:2])
print('21:', min([s for s in range(17, 100) if f(s, 4) and not f(s, 2)]))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие