ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 19031. Основная волна 2024

Задание 19

Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежит куча камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в кучу один или три камня либо увеличить количество камней в куче в два раза. У каждого игрока есть неограниченное количество камней, чтобы делать ходы.

Игра завершается в тот момент, когда количество камней в куче становится не менее 67. Победителем считается игрок, сделавший последний ход, т.е. первым получивший кучу из 67 камней или больше. В начальный момент в куче было S камней; 1 ≤ S ≤ 66.

Будем говорить, что игрок имеет выигрышную стратегию, если он может выиграть при любых ходах противника.

Укажите минимальное значение S, при котором Петя не может выиграть за один ход, но при любом ходе Пети Ваня может выиграть своим первым ходом

Задание 20

Для игры, описанной в задании 19, найдите два наименьших значения S, при которых у Пети есть выигрышная стратегия, причём одновременно выполняются два условия:

− Петя не может выиграть за один ход;

− Петя может выиграть своим вторым ходом независимо от того, как будет ходить Ваня.

Найденные значения запишите в ответе в порядке возрастания.

Задание 21

Для игры, описанной в задании 19, найдите значение S, при котором одновременно выполняются два условия:

– у Вани есть выигрышная стратегия, позволяющая ему выиграть первым или вторым ходом при любой игре Пети;

– у Вани нет стратегии, которая позволит ему гарантированно выиграть первым ходом.

Если найдено несколько значений S, в ответе запишите наименьшее из них.

def f(x, s):
    if x >= 67:
        return s % 2 == 0

    if s == 0:
        return False

    h = [f(x + 1, s - 1),
         f(x + 3, s - 1),
         f(x * 2, s - 1)]
    return any(h) if (s + 1) % 2 == 0 else all(h)


print('19:', min([s for s in range(1, 66) if
                  f(s, 2)]))
print('20:', *[s for s in range(1, 66) if
               f(s, 3) and not
               f(s, 1)][:2])
print('21:', min([s for s in range(1, 66) if
                  f(s, 4) and not
                  f(s, 2)]))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие