ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 16102. Типовая задача

Алгоритм вычисления значения функции F(n), где n – целое неотрицательное число, задан следующими соотношениями:

F(n)=n при n < 3;
F(n)= 2 × (n-1) + F(n-1) + 2, если n > 2 и при этом n чётно;
F(n)= 2 × (n+1) + F(n-2) - 5, если n > 2 и при этом n нечётно

Чему равно значение функции F(32)?

def f(n):
    if n > 2 and (n % 2 == 0):
        return 2 * (n - 1) + f(n - 1) + 2
    elif n > 2 and n % 2:
        return 2 * (n + 1) + f(n - 2) - 5
    elif 0 < n < 3:
        return n


print(f(32))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие