ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 16044. Демоверсия 2026

Алгоритм вычисления значения функции F(n) и G(n), где n – целое число, задан следующими соотношениями:

F(n) = 2 × (G(n-3) + 8);
G(n) = 2 × n, если n<10;
G(n) = G(n-2) + 1, если n ≥ 10;

Чему равно значение выражения F(15548)?

from functools import lru_cache


def f(n):
    return 2 * (g(n - 3) + 8)


@lru_cache()
def g(n):
    if n < 10:
        return 2 * n
    else:
        return g(n - 2) + 1


for n in range(10, 15548):
    f(n)

print(f(15548))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие