ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 16039. Основная волна 2025

Алгоритм вычисления значения функции F(n), где n – целое число, задан следующими соотношениями:

F(n)=n при n<10;
F(n)=3 × n + F(n-3), если n ≥ 10

Чему равно значение выражения (F(6250)+2 × F(6244))/F(6238)?

from functools import lru_cache


@lru_cache()
def f(n):
    if n < 10:
        return n
    else:
        return 3 * n + f(n - 3)


for n in range(10, 6251):
    f(n)

print((f(6251) + 2 * f(6244)) // f(6238))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие