ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 16032. Демоверсия 2025

Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями:

F(n)=1 при n=1;
F(n)=(n-1) × F(n-1), если n > 3

Чему равно значение выражения (F(2024)+2 × F(2023))/F(2022)?

from functools import lru_cache


@lru_cache()
def f(n):
    if n == 1:
        return 1
    else:
        return (n - 1) * f(n - 1)


for n in range(1, 2026):
    f(n)

print((f(2024) + 2 * f(2023)) // f(2022))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие