ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 16023. ЕГКР 2024

Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями:

F(n)=1 при n≤ 3;
F(n)=(n+3) × F(n-2), если n>3

Чему равно значение выражения F(2028)/ F(2024)?

def f_iter(n):
    if n <= 3:
        return 1
    cache = [1, 1, 1, 1]
    for i in range(4, n + 1):
        cache.append((i + 3) * cache[i - 2])
    return cache[n]


print(f_iter(2028) // f_iter(2024))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие