ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 16006. Авторские варианты

Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями:

F(n)=n при n ≤ 3;
F(n)=(n-2) × F(n-2), если n > 3

Чему равно значение выражения (F(1024)+2 × (F(1024) — F(1022)))/F(1020)?

from functools import lru_cache


@lru_cache()
def f(n):
    if n <= 3:
        return n
    else:
        return (n - 2) * f(n - 2)


for n in range(1, 1025):
    f(n)

print((f(1024) + 2 * (f(1024)-f(1022))) / f(1020))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие