ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 16003. ЕГКР

Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями:

F(n)=n при n<5;
F(n)=2 × n × F(n-4), если n ≥ 5

Чему равно значение выражения (F(13766) — 9 × F(13762))/F(13758)?

from functools import lru_cache


@lru_cache()
def f(n):
    if n < 5:
        return n
    return 2 * n * f(n - 4)


for n in range(5, 13767):
    f(n)

print((f(13766) - 9 * f(13762)) // f(13758))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие