ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 16000. Демоверсия

Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями:

F(n)=n при n>2024;
F(n)=n × F(n+1), если n≤2024

Чему равно значение выражения F(2022)/ F(2024)?

def f(n):
    if n > 2024:
        return n
    else:
        return n * f(n + 1)


print(f(2022) // f(2024))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие