ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 15201. Авторская задача

Найдите максимальное значение параметра А, при котором выражение (x + 2 ≤ 50) ∨ (y < x+10) ∨ (x ≥ A) тождественно истинно (т.е. принимает значение 1) при любых целых натуральных x и y.

def f(A):
    for x in range(1, 1000):
        for y in range(1, 1000):
            res = (x + 2 <= 50) or (y < x + 10) or (x >= A)
            if not res:
                return False
    return True


for A in range(1, 1000):
    if f(A):
        print(A)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие