ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14051. ЕГКР 2026

Значение арифметического выражения 3 ∙ 279 + 2 ∙ 276 + 273 – x, где x - целое положительное число, не превышающее 27000, записали в 27-ричной системе счисления.

Определите наименьшее значение x, при котором в 27-ричной записи числа, являющегося значением данного арифметического выражения, содержится ровно 6 нулей.

В ответе запишите число в десятичной системе счисления.

ans = []
for x in range(1, 27_001):
    num = 3*27**9 + 2*27**6 + 27**3 - x
    cnt = 0
    while num:
        if num % 27 == 0: cnt += 1
        num //= 27
    if cnt == 6:
        ans.append(x)

print(min(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие