ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14037. ЕГКР 2025

Операнды арифметического выражения записаны в системе счисления с основанием 25:

11353x1225 + 135x2125

В записи чисел переменной x обозначена неизвестная цифра из алфавита 25-ричной системы счисления. Определите наибольшее значение x, при котором значение данного арифметического выражения кратно 24.

Для найденного x вычислите частное от деления значения арифметического выражения на 24 и укажите его в ответе в десятичной системе счисления. Основание системы счисления указывать не нужно.

from string import printable as alph

ans = []
for x in alph[:25]:
    num_1 = int(f'11353{x}12', 25)
    num_2 = int(f'135{x}21', 25)
    num = num_1 + num_2
    if num % 24 == 0:
        ans.append([x, num // 24])

print(max(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие