ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14028. ФИПИ 2024

Определите количество цифр с числовым значением, превышающим 9, в 27-ричной записи числа, заданного выражением:

2 ∙ 7292014 + 2 ∙ 2432016 – 2 ∙ 812018 + 2 ∙ 272020 – 2 ∙ 92022 – 2024

num = 2*729**2014 + 2*243**2016 - 2*81**2018 + 2*27**2020 - 2*9**2022 - 2024

cnt = 0
while num:
    if num % 27 > 9: cnt += 1
    num //= 27

print(cnt)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие