ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14000. Демоверсия

Значение арифметического выражения 7170 + 7100 — x, где x – целое положительное число, не превышающее 2030, записали в 7-ричной системе счисления.

Определите наибольшее значение x, при котором в 7-ричной записи числа, являющегося значением данного арифметического выражения, содержится ровно 71 нуль.

В ответе запишите число в десятичной системе счисления.

# x целое положительное не превышает 2030
# Нужно найти наибольшее => инвертируем range
for x in range(1, 2031)[::-1]:
    # Выражение
    num = 7 ** 170 + 7 ** 100 - x
    # Подсчёт нулей
    count = 0
    # Поиск нулей в 7-чной записи
    while num:
        if num % 7 == 0:
            count += 1
        num //= 7
    # Если ровно 71 нуль
    if count == 71:
        # Выводим x
        print(x)
        # Завершаем цикл
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие