ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 8102. Типовая задача

Сколько существует различных трёхзначных чисел, записанных в пятеричной системе счисления, в записи которых цифры следуют слева направо в невозрастающем порядке?

from itertools import product

count = 0
for val in product('01234', repeat=3):
    val = "".join(val)
    # Можно использовать val[0] >= val[1] >= val[2]
    if val[0] != '0' and list(val) == sorted(val, reverse=True):
        count += 1

print(count)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие