ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 8100. Типовая задача

Определите количество пятизначных чисел, записанных в восьмеричной системе счисления, в записи которых ровно две цифра 4, и при этом никакая нечётная цифра не стоит рядом с цифрой 4.

from itertools import product

alph = '01234567'
wrong_pairs = {'14', '34', '54', '74',
               '41', '43', '45', '47'}


count = 0
for val in product(alph, repeat = 5):
    val = "".join(val)
    if (val[0] != '0'
            and val.count('4') == 2
            and all(pair not in val for pair in wrong_pairs)):
        count += 1

print(count)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие