ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 8032. Демоверсия 2025

Определите количество 12-ричных пятизначных чисел, в записи которых ровно одна цифра 7 и не более трёх цифр с числовым значением, превышающим 8.

import string
from itertools import product

# Алфавит из условия
alph = string.printable[:12]

count = 0
for val in product(alph, repeat=5):
    val = "".join(val)
    if val[0] != '0' and val.count('7') == 1 and val.count('9') + val.count('a') + val.count('b') <= 3:
        count += 1

print(count)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие