ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 8029. Основная волна 2024

Определите количество 15-ричных пятизначных чисел, в записи которых ровно одна цифра 8 и не менее двух цифр с числовым значением, превышающим 9.

import string
from itertools import product

# Алфавит из условия
alph = string.printable[:15]


# Не менее двух цифр с числовым значением, превышающим 9
def over_9(digits):
    alph_over_9 = string.printable[10:15]
    sum_of_digits = sum([1 for i in digits if i in alph_over_9])
    if sum_of_digits >= 2:
        return True
    else:
        return False


count = 0
for val in product(alph, repeat=5):
    val = "".join(val)
    if val[0] != '0' and val.count('8') == 1 and over_9(val):
        count += 1

print(count)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие