ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 5100. Типовая задача

Автомат получает на вход трёхзначное число. По этому числу строится новое число по следующим правилам.

  1. Перемножаются все цифры исходного числа
  2. Суммируются все цифры исходного числа
  3. Полученные два числа записываются друг за другом в порядке невозрастания (без разделителей)

Пример. Исходное число: 621. Произведение цифр: 6 х 2 х 1 = 12; сумма цифр: 6 + 2 + 1 = 9. Результат: 129.

Укажите наибольшее число, при обработке которого автомат выдаёт число 33821.

def get_digits_mult(num):
    return int(str(num)[0]) * int(str(num)[1]) * int(str(num)[2])


def get_digits_sum(num):
    return int(str(num)[0]) + int(str(num)[1]) + int(str(num)[2])


for num in range(99, 1000)[::-1]:
    result = str(get_digits_mult(num)) + str(get_digits_sum(num))
    if result == '33621':
        print(num)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие