ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 5043. Пересдача 2025

На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом.

  1. Строится двоичная запись числа N.
  2. Далее эта запись обрабатывается по следующему правилу:
    1. если число чётное, то к двоичной записи числа слева дописывается 10;
    2. если число нечётное, то к двоичной записи числа слева дописывается 1 и справа дописывается 01
      Полученная таким образом запись является двоичной записью искомого числа R.
  3. Результат переводится в десятичную систему и выводится на экран.

 
Например, для исходного числа 410 = 1002 результатом является число 2010 = 101002, а для исходного числа 510 = 1012 это число 5310 = 1101012.

Укажите максимальное число N, после обработки которого с помощью этого алгоритма получается число R, меньшее, чем 30. В ответе запишите это число в десятичной системе счисления.

ans = []
for N in range(1, 10_000):
    R = f'{N:b}'
    if N % 2 == 0:
        R = '10' + R
    else:
        R = '1' + R + '01'
    R = int(R, 2)
    if N in (4, 5):  # Проверка примеров
        print(R)
    if R < 30:
        ans.append(N)

print(max(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие