ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 5032. Демоверсия 2025

На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом.

  1. Строится двоичная запись числа N.
  2. Далее эта запись обрабатывается по следующему правилу:
    • если число чётное, то к двоичной записи числа слева дописывается 10;
    • если число нечётное, то к двоичной записи числа слева дописывается 1 и справа дописывается 01.
      Полученная таким образом запись является двоичной записью искомого числа R.
  3. Результат переводится в десятичную систему и выводится на экран.

Например, для исходного числа 410 = 1002 результатом является число 2010 = 101002, а для исходного числа 510 = 1012 это число 5310 = 1101012.

Укажите максимальное число R, которое может быть результатом работы данного алгоритма, при условии, что N не больше 12.

В ответе запишите это число в десятичной системе счисления.

res = []
# Сразу укажем, что N не больше 12
for N in range(1, 13):
    # Строим двоичную запись
    R = f'{N:b}'
    # Если число чётное
    if N % 2 == 0:
        # Дописываем слева 10
        R = '10' + R
    # Иначе (если нечётное)
    else:
        # Слева 1 справа 01
        R = '1' + R + '01'
    # Переводим в десятичную
    R = int(R, 2)
    # Формируем ответ
    res.append(R)

print(max(res))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие