ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 5008. Основная волна 2022

На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом.

  1. Строится двоичная запись числа N.
  2. Далее эта запись обрабатывается по следующему правилу:
    1. если сумма цифр в двоичной записи числа чётная, то к этой записи справа дописывается 1, а затем два левых разряда заменяются на 10;
    2. если сумма цифр в двоичной записи числа нечётная, то к этой записи справа дописывается 0, а затем два левых разряда заменяются на 11.

 
Полученная таким образом запись является двоичной записью искомого числа R.

Например, для исходного числа 610 = 1102 результатом является число 10012 = 910, а для исходного числа 410 = 1002 результатом является число 11002 = 1210.

Укажите максимальное число R, которое может быть получено при обработке числа N, меньшего 16. В ответе запишите это число в десятичной системе счисления.

ans = []
for N in range(1, 16):
    R = f'{N:b}'
    if sum(map(int, R)) % 2 == 0:
        R = '10' + R[2:] + '1'
    else:
        R = '11' + R[2:] + '0'
    R = int(R, 2)
    if N in (4, 6): # Проверка примеров
        print(R)
    ans.append(R)

print(max(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие