ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 26039. Основная волна 2025

На производстве штучных изделий N деталей должны быть отшлифованы и окрашены. Для каждой детали известно время её шлифовки и время окрашивания. Детали пронумерованы начиная с единицы. Параллельная обработка деталей не предусмотрена. На ленте транспортёра имеется N мест для каждой из N деталей.

На ленте транспортёра детали располагают по следующему алгоритму:

— все 2N чисел, обозначающих время окрашивания и шлифовки для N деталей, упорядочивают по возрастанию;
 — если минимальное число в этом упорядоченном списке — это время шлифовки конкретной детали, то деталь размещают на ленте транспортёра на первое свободное место от её начала;
 — если минимальное число — это время окрашивания, то деталь размещают на первое свободное место от конца ленты транспортёра
 — если число обозначает время окрашивания или шлифовки уже рассмотренной детали, то его не принимают во внимание.

Этот алгоритм применяется последовательно для размещения всех N деталей.

Определите номер последней детали, для которой будет определено её место на ленте транспортёра, и количество деталей, которые
будут отшлифованы до неё.

Входные данные

В первой строке входного файла находится натуральное число N (N < 1000)- количество деталей. Следующие N строк содержат пары чисел, обозначающих соответственно время шлифовки и время окрашивания конкретной детали (все числа натуральные, различные).

Запишите в ответе два натуральных числа: сначала номер последней детали, для которой будет определено её место на ленте транспортёра, затем количество деталей, которые будут отшлифованы до неё.

Типовой пример организации данных во входном файле

5
30 50
100 155
150 170
10 160
120 55

При таких исходных данных порядок расположения деталей на ленте транспортёра следующий: 4, 1, 2, 3, 5. Последней займёт своё место на ленте транспортёра деталь 3. При этом до неё будут отшлифованы три детали.

Типовой пример имеет иллюстративный характер. Для выполнения задания используйте данные из прилагаемых файлов.

data = []
with open('2619.txt') as file:
    next(file)
    id_detail = 1
    for line in file:
        parts = line.strip().split()
        grinding = int(parts[0])
        coloring = int(parts[1])
        min_time = min(grinding, coloring)
        if min_time == grinding:
            min_time_op = "Шлифовка"
        else:
            min_time_op = "Окрашивание"
        detail = {
            "Номер детали": id_detail,
            "Шлифовка"    : grinding,
            "Окрашивание" : coloring,
            "Минимальное время": min_time,
            "Операция": min_time_op
            }
        data.append(detail)
        id_detail +=1

data = sorted(data, key=lambda x: x["Минимальное время"])

details_before = sum(1 for detail in data[:-1] if detail["Операция"] == "Шлифовка")

print(data[-1]["Номер детали"], details_before)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие