ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 24035. Апробация 2025

Текстовый файл состоит из символов A, B, C, D, E и F.

Определите максимальное количество идущих подряд символов в прилагаемом файле, среди которых пара символов AB (в указанном порядке) встречается ровно 100 раз.

with open('2414.txt', 'r') as file:
    data = file.readline()

data = data.replace("AB", "A B").split()

length = 0

for i in range(len(data) - 100):
    substring = "".join(data[i:i + 101])
    length = max(length, len(substring))
print(length)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие