ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 24022. Демоверсия 2024

Текстовый файл состоит из символов T, U, V, W, X, Y и Z.

Определите в прилагаемом файле максимальное количество идущих подряд символов (длину непрерывной подпоследовательности), среди которых символ T встречается ровно 100 раз.

with open('2404.txt', 'r') as file:
    data = file.readline()

lt = 0
max_len = 0
cnt = 0

for rt in range(len(data)):
    # Если правая граница это 'T', увеличиваем счётчик
    if data[rt] == 'T':
        cnt += 1

    # Пока количество 'T' больше 100, сдвигаем левый указатель
    while cnt > 100:
        if data[lt] == 'T':
            cnt -= 1
        lt += 1

    # Если количество 'T' равно 100, обновляем максимальную длину
    if cnt == 100:
        max_len = max(max_len, rt - lt + 1)

print(max_len)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие