ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 2029. Основная волна 2024

Миша заполнял таблицу истинности логической функции F = ¬(x → z) ∨ (y ≡ w) ∨ y, но успел заполнить лишь фрагмент из трёх различных её строк, даже не указав, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.

F
1 0 0
1 0 0
0 0

Определите, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.

В ответе напишите буквы w, x, y, z в том порядке, в котором идут соответствующие им столбцы (сначала буква, соответствующая первому столбцу; затем буква, соответствующая второму столбцу, и т.д.). Буквы в ответе пишите подряд, никаких разделителей между буквами ставить не нужно.

from itertools import permutations, product


def f(x, y, z, w):
    return not (x <= z) or (y == w) or y


for a1, a2, a3, a4, a5, a6, a7 in product([0, 1], repeat=7):
    table = (
        (1, 0, a1, a2),
        (a3, 1, 0, a4),
        (0, a5, a6, a7)
    )
    if len(table) == len(set(table)):
        for perm in permutations('xyzw'):
            func = [f(**dict(zip(perm, row))) for row in table] == [0, 0, 0]
            if func:
                print(*perm)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие