ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 2002. Основная волна 2021

Логическая функция F задаётся выражением (¬a ∧ ¬b) ∨ (b ≡ c) ∨ d.На рисунке приведён частично заполненный фрагмент таблицы истинности функции F, содержащий неповторяющиеся строки.

? ? ? ? F
1 0
1 0 1 0
0 0 1 1 0

Определите, какому столбцу таблицы истинности функции F соответствует каждая из переменных a, b, c, d.

В ответе напишите буквы a, b, c, d в том порядке, в котором идут соответствующие им столбцы. Буквы в ответе пишите подряд, никаких разделителей между буквами ставить не нужно.

from itertools import product, permutations


def f(a, b, c, d):
    return (not a and not b) or (b == c) or d


for i in product([0, 1], repeat=4):
    table = [
        (i[0], i[1], 1, i[2]),
        (1, 0, i[3], 1),
        (0, 0, 1, 1)
    ]
    if len(table) == len(set(table)):
        for title in permutations('abcd'):
            check = [f(**dict(zip(title, row))) for row in table] == [0, 0, 0]
            if check:
                print(*title, sep='')

Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие